Recent Posts

Pages: 1 [2] 3 4 ... 10
11
Computational Fluid Dynamics / Embedded velocity
« Last post by camaosos on April 10, 2017, 09:42:05 AM »
Dear Kratos team,

I was checking today the  fractional_step_discontinuous.cpp file. However I do not understand very well from a theoretical point of view how it is the embedded velocity imposed into the element and the penalty coefficient used for that. I can understand the weak imposition in the mass conservation equation but not very well how the velocity is imposed in the momentum equation. Is there some theory or article which explains this procedure?

Thank you for your help!

Carlos

12
Compilation / Re: Kratos for Dummies (ImportError)
« Last post by Peter on March 15, 2017, 11:45:35 AM »
Thanks a lot. What a stupid mistake :) I just typed in "python3" instead of "python" and everything worked.
Thanks
Peter
13
Compilation / Re: Kratos for Dummies (ImportError)
« Last post by Miguel Angel Celigueta on March 14, 2017, 02:40:00 PM »
Hi,
Take a look at this post: http://kratos-wiki.cimne.upc.edu/forum/index.php?topic=17.0
Maybe you have to use 'python3' instead of 'python'
Regards,
Miguel Ángel
14
Compilation / Kratos for Dummies (ImportError)
« Last post by Peter on March 14, 2017, 02:13:37 PM »
Hallo,

I reinstalled Kratos and everything worked fine during compilation. But I always get the same error when I try to run an test example:

File "pure_diffusion_example.py", line 6, in <module>
   from KratosMultiphysics Import *
File ".../Kratos/KratosMultiphysics/__init__.py, line 13, in <module>
   from Kratos Import*
ImportError: dynamic module does not define init function (initKratos)

At first I thought that I set one environment variable wrongly but PATH, LD_LIBRARY_PATH and PYTHONPATH are set correctly.

So does anyone have an idea what the Problem could be??

Thanks
Peter
15
Compilation / Problem type generator
« Last post by AWinterstein on February 09, 2017, 08:34:47 AM »
Hi together,

I want to use the problem type generator function, but the explanation how to use it in the wiki seems to be outdated. Can anyone give me a short introduction how to use it?

Thank you in advance.

Regards

Andreas
16
Kratos Core / Cross Product implementation
« Last post by Miguel Angel Celigueta on February 02, 2017, 05:13:45 PM »
Hi,
I just realized that the kratos/utilities/math_utils.h contains several different implementations of the CrossProduct.
In some cases, the operation is a x b, but in some other cases, it's b x a. Could they be unified under a single criterion?
I guess many people will be using them already, so any change can break many codes...
Thanks,
Miguel Angel
17
Compilation / Re: Compilation Issue using VS 2015
« Last post by Long on February 02, 2017, 02:55:05 PM »
Hello,

I am trying to compile Kratos in debug mode using VS2015.
For this purpose, I installed the Python version 3.5.3 together with the debug binaries. After that I compiled the boost 1.59 in debug mode. I created a new folder cmake_build_debug and I modified my configure file as follows:

-DBOOST_ROOT="E:\Kratos_Libs\boost_1_59_0_debug\boost_1_59_0"              ^
-DPYTHON_LIBRARY="C:\Python35\libs\python35.lib"                                        ^
-DPYTHON_INCLUDE_PATH="C:\Python35\include"                                            ^
-DLAPACK_LIBRARIES="E:\Kratos_Libs\BLASandLAPACK\liblapack.lib"                 ^
-DBLAS_LIBRARIES="E:\Kratos_Libs\BLASandLAPACK\libblas.lib"                        ^

here I changed the boost_root to the new boost libraries compiled in debug mode, and adjust the python libraries as well as its path to version 3.5.

After compiling, I got 3 errors shown below:

1.
Error   D8016   '/O2' and '/RTC1' command-line options are incompatible   
project:tetgen
File:   E:\kratos\cmake_build_debug\applications\MeshingApplication\custom_external_libraries\tetgen\tetgen1.4.3\cl
Line:   1

2.

Error   LNK1104   cannot open file 'custom_external_libraries\tetgen\tetgen1.4.3\Debug\tetgen.lib'   
project: KratosMeshingApplication   
file: E:\kratos\cmake_build_debug\applications\MeshingApplication\LINK   
line: 1

3.
Error   LNK1104   cannot open file 'python35_d.lib'   runkratos   
file: E:\kratos\cmake_build_debug\embedded_python\LINK   
line: 1

For the error 3: I checked in my "PYTHON_INCLUDE_PATH" (C:\Python35\libs) and the file "python35_d.lib" does exist. I also added this directory to the system PATH for all users.

Can you please tell me how I can fix this issue?
Thanks in advance.

Best,
Long








18
DEM / Re: Windows compilation errors with Visual Studio 14 2015 Win64
« Last post by Josep Maria on February 02, 2017, 10:10:33 AM »
Miquel Angel,

  I think that in parallel loops using OpenMP the continue statment has some restrictions if you want it to be compiled as parallel.
But it seems it only happens in Windows.

Regards

Josep Maria

19
DEM / Re: Windows compilation errors with Visual Studio 14 2015 Win64
« Last post by Miguel Angel Celigueta on February 02, 2017, 12:13:49 AM »
I just fixed two of the three errors. The third one: error C2044: instrucción continue no válida (illegal continue)
makes no sense to me, as this 'continue' is indeed inside a 'for' loop...
Regards,
Miguel Ángel
20
Kratos Core / Re: Serialization of the WeakPointerVector is missing
« Last post by Josep Maria on February 01, 2017, 11:55:49 PM »
Hi Pooyan,

   Ok I understand and I assume the argument.

I use to rebuild the WeakPointerVectors but I save and load them. This is because they are inserted in these DataValueContainer's (mData) of some of the core classes and is the DataValueContainer (mData) the serialized variable. One must be very careful to take into account that the reloaded WeakPointerVector from a restart file is empty.

Some extra rebuilds have to be done after reading a restart to have all working data coherent.

Thank you for your prompt response

Best regards

Josep Maria
Pages: 1 [2] 3 4 ... 10