Author Topic: [SOLVED] Linking problem with boost::python::detail::init_module (Win 7, x64)  (Read 2833 times)

tsvilans

  • Newbie
  • *
  • Posts: 4
Hi,

I've been following the instructions here and everything worked fine until I'm compiling the release build of INSTALL in VS2015.

For 8-9 of the projects I get:

Code: [Select]
Creating library C:/svn/kratos/cmake_build/applications/FluidDynamicsApplication/Release/KratosFluidDynamicsApplication.lib and object C:/svn/kratos/cmake_build/applications/FluidDynamicsApplication/Release/KratosFluidDynamicsApplication.exp
3>fluid_dynamics_python_application.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) struct _object * __cdecl boost::python::detail::init_module(struct PyModuleDef &,void (__cdecl*)(void))" (__imp_?init_module@detail@python@boost@@YAPEAU_object@@AEAUPyModuleDef@@P6AXXZ@Z) referenced in function PyInit_KratosFluidDynamicsApplication
3>C:\svn\kratos\cmake_build\applications\FluidDynamicsApplication\Release\KratosFluidDynamicsApplication.pyd : fatal error LNK1120: 1 unresolved externals

I tried both with Boost 1.59 and 1.61.

Am I missing something? Any ideas?

Much thanks!

Tom
« Last Edit: August 16, 2016, 12:02:02 AM by Miguel Angel Celigueta »

tsvilans

  • Newbie
  • *
  • Posts: 4
It is now still compiling, but it seems that the error is gone. Looks like it was a Python version mismatch. Re-compiled Boost with the same Python version as I'm using for Kratos and it seems to be working! Consider this solved...